HanDs
NO.2

XEN虚拟机监控器出现“致命”漏洞 





学习中请遵循国家相关法律法规,黑客不作恶。没有网络安全就没有国家安全

本站需要登陆后才能查看

xen_project_logo_dualcolor_1000x416.png

XEN一向以高性能、占用资源少著称,赢得了IBM、AMD、HP、Red Hat和Novell等众多世界级软硬件厂商的高度认可和大力支持,不少国内外企事业用户用XEN来搭建高性能的虚拟化平台。然而,XEN近期被指出一个“致命”漏洞。

来自Quarkslab的安全专家Jérémie Boutoille说,他已经在Xen虚拟机监控器上发现了一个关键漏洞,该漏洞会导致潜在的权限提升风险。

使用x86硬件的半虚拟化(PV)用户需要注意:该漏洞版本已确定为CVE-2016-6258,并且能够影响Xen的所有版本。硬件虚拟机(HVM)和ARM的用户则无需担心。

研究人员在Xenbits网站上发出公告:

“只运行硬件虚拟机(HVM)的用户能避免这一漏洞。”

漏洞原理

Xen平台PV模式下运行的虚拟机被披露存在权限提升漏洞。当满足一定条件,用于控制验证页表的代码可被绕过,导致PV模式下的普通用户(如Guest)可使用超级页表映射权限重新定义可写入的映射。由于漏洞产生原因为页表关联权限绕过,即使在Xen系统配置“allowsuperpage”命令行选项为“否”的情况下也会受到漏洞的影响。综合利用漏洞,可提升普通用户权限,进而控制整个虚拟机系统,构成用户主机数据泄漏风险。

漏洞补丁

Qubes操作系统(Qubes充分利用了虚拟化技术(基于安全虚拟机Xen))的开发者——著名的波兰女黑客Joanna Rutkowska说:

该漏洞是致命的。外界在短时间内就XEN PV虚拟化模块代码再次出现漏洞进行了公开讨论,黑客能够通过Xsa-182漏洞完全控制运行在xen上的虚拟机。我们不会因为已经完成的补丁而轻易遗忘这个漏洞。

补丁可在这里下载。

*参考来源:betanews。FB小编bimeover编译,


学习中请遵守法律法规,本网站内容均来自于互联网,本网站不负担法律责任
XEN 虚拟机监控器出现 致命 漏洞
#1楼
发帖时间:2016-8-8   |   查看数:0   |   回复数:0
游客组